Welcome Guest. ( logon | register )   
FAQ Member List Albums Today's Posts Search

PointedThree :  Sedan Forums : W126 S,SE,SEC,SEL,SD,SDL Class : 560 SEL Won't Restart

Page 1 of 1 1
560 SEL Won't Restart
Topic Tools Message Format
Author
Posted 12/7/2007 9:22 AM
Puzzlman

Date registered: Dec 1899
Location:
Vehicle(s):
560 SEL Won't Restart

I have a 1990 560 SEL with 160000 miles. Upon idle the engine rpm accelerated and then quit. Would npt restart after. Cranks fine but does not appear to be getting any fuel to fire. Had the O2 sensor replaced prior to problem to pass emmissions. Before I spend a bunch of money on a tow and service and thoughts on possible simple solutions. Thanks.
#99270
Top of the page Bottom of the page
Author
Posted 12/8/2007 1:39 AM
nomad

Date registered: Dec 1899
Location:
Vehicle(s):
RE: 560 SEL Won't Restart

Not sure on your problem but...

Check this out for more, there's info on checking and repairing the idle control unit

http://www.mbcoupes.com/repairarticles/idlecontrol/highidle.htm

or here:

http://www.benzworld.org/forums/w126-s-se-sec-sel-sd-sdl-class/1342...

I hope they can help with your problem

Edited by nomad 12/8/2007 1:41 AM
#99441 - in reply to #99270
Top of the page Bottom of the page
Author
Posted 12/11/2007 5:33 PM
Nutz
Expert


Date registered: Apr 2006
Location:
Vehicle(s):
Posts: 2026
2000
Re: 560 SEL Won't Restart

Reference mark transmitter on these?
#100037 - in reply to #99441
Top of the page Bottom of the page
« View previous thread :: View next thread »
Page 1 of 1 1
Forum Jump :
All times are EST.  The time is now 2:18:56 PM.

Execution: 0.359 seconds, 91 cached, 9 executed.