Welcome Guest. ( logon | register )   
FAQ Member List Albums Today's Posts Search

PointedThree :  Vans, Trucks, SUVs and Other Forums : G-Class : TC In Neutral Issue

Page 1 of 1 1
TC In Neutral Issue
Topic Tools Message Format
Author
Posted 9/4/2021 10:44 PM
ychung
Veteran


Date registered: Aug 2015
Location: SO CAL
Vehicle(s): 2004 G500, 2014 ML350, 2008 S550
Posts: 193
100
TC In Neutral Issue

Hello
I know it’s been covered here many times on TC in Neutral Issue, and I had the same issue a few times previously but I was able to reset it by playing with L and H buttons.
However, when this happened again today, I wasn’t able to reset it. I can somehow, after many tries, get H to show up but goes back to blank square or I move the car 10 yards.
The other problem is that I am 100 miles away from home in Palm Desert, CA
Does anyone know a good MB independent shop in Palm Desert/Palm Spring area?
Is there other method or trick that I can do to make it work to drive home?
Thank you
#242982
Top of the page Bottom of the page
Author
Posted 9/4/2021 11:47 PM
ychung
Veteran


Date registered: Aug 2015
Location: SO CAL
Vehicle(s): 2004 G500, 2014 ML350, 2008 S550
Posts: 193
100
Re: TC In Neutral Issue

Another issue is that even when it’s in parked position, it still rolls just like in neutral position.
#242983 - in reply to #242982
Top of the page Bottom of the page
Author
Posted 9/6/2021 8:07 PM
Fred V
Regular


Date registered: Apr 2014
Location: Green Mnts
Vehicle(s): 02 G500
Posts: 82
50
Re: TC In Neutral Issue

Mine is a 2002 and I had the "TC in neutral" problem ~5 yrs ago. Replaced the transfer case motor which solved the problem back then. Had same problem again late last fall. The vehicle was in high range at the time so I unplugged the electrical connector to the TC motor. That prevented the motor from moving the transfer case to neutral or low. Not a problem as I rarely use low. Yes, you get an error message but vehicle drove fine and then this spring I got the TC motor replaced.
#242987 - in reply to #242983
Top of the page Bottom of the page
Author
Posted 10/4/2021 4:38 PM
ychung
Veteran


Date registered: Aug 2015
Location: SO CAL
Vehicle(s): 2004 G500, 2014 ML350, 2008 S550
Posts: 193
100
RE: TC In Neutral Issue

My mechanic replaced the T/C module since it wasn't communicating but we still have the same problem.
He's telling me that there is no other choice but to replace the transfer case.
Where should I start to look for a used one?
Thank you,
#243047 - in reply to #242982
Top of the page Bottom of the page
Author
Posted 10/7/2021 9:37 PM
Fred V
Regular


Date registered: Apr 2014
Location: Green Mnts
Vehicle(s): 02 G500
Posts: 82
50
Re: TC In Neutral Issue


T/C module or T/C motor? As I recall I bought both as the thinking at the time was that both needed to be replaced to fix the "TC in Neutral" problem. I had only the motor replaced as the module was deep in the center console. The local garage was reluctant to tackle the module job and it may have required input from the Merc software, which they don't have. This was yrs ago now hence I can't recall exactly why only the T/C motor was replaced but there was some good reason at the time. The T/C motor is a fairly straightforward job from below. Replacing the T/C motor did the trick and the module is still in its box on a shelf in my garage. In fact, am on the second T/C motor now and the original T/C module is still in place. If the T/C motor has not been replaced I would start there.
#243052 - in reply to #243047
Top of the page Bottom of the page
Author
Posted 10/12/2021 11:19 AM
ychung
Veteran


Date registered: Aug 2015
Location: SO CAL
Vehicle(s): 2004 G500, 2014 ML350, 2008 S550
Posts: 193
100
Re: TC In Neutral Issue

The both T/C module and the T/C motor were replaced but I have the same issue.
We have ordered a tiny bushing that goes between the shaft and the shifting fork since my mechanic thinks it's sort of worn out.
It's like a Hail Mary, and if doesn't work, I may have no choice but to get an used transfer case.
My mechanic thinks that the transfer case shouldn't go bad to cause this issue, but he also thinks that if just replace the transfer case it should work .
#243063 - in reply to #243052
Top of the page Bottom of the page
Author
Posted 10/12/2021 1:49 PM
otiswesty
Expert




Date registered: Jun 2007
Location: Portland, Oregon
Vehicle(s): 463.241, 461.213
Posts: 2860
2000
RE: TC In Neutral Issue

Look at Karl's response in this thread.
http://www.pointedthree.com/disc/forums/showthread.asp?tid=22238&po...

Position of TC shift motor needs to be relearned. Also there can be issues with the wiring to the TC motor. I have not really heard of TC failure being manifested as a shift or neutral issue. I would have a transmission shop open it up before buying a replacement if you do get to that stage though.
#243064 - in reply to #242982
Top of the page Bottom of the page
Author
Posted 10/12/2021 5:55 PM
ychung
Veteran


Date registered: Aug 2015
Location: SO CAL
Vehicle(s): 2004 G500, 2014 ML350, 2008 S550
Posts: 193
100
Re: TC In Neutral Issue

After module replacement, the adaptation was done and the harness was replaced as well, new module, motor and cable.
I will let you know once we get the new bushing although I don't have high hope now.
Thank Fred and otiswesty for your comments.
#243065 - in reply to #243064
Top of the page Bottom of the page
Author
Posted 10/21/2021 2:23 PM
ychung
Veteran


Date registered: Aug 2015
Location: SO CAL
Vehicle(s): 2004 G500, 2014 ML350, 2008 S550
Posts: 193
100
RE: TC In Neutral Issue

I am happy to post here that it works now.
The module was needed since it wasn't communicating but I am not sure if I really needed a new motor.
But I now have a peace of mind that I won't any issue with transfer case for a long time.
#243092 - in reply to #242982
Top of the page Bottom of the page
« View previous thread :: View next thread »
Page 1 of 1 1
Forum Jump :
All times are EST.  The time is now 8:05:34 AM.

Execution: 0.267 seconds, 99 cached, 9 executed.